I earned an IBM Badge

I have been issued an IBM Badge as Certification Exam Developer


IBM Connections Mobile APNS certificates expiring on 1/29/2016

IBM has just released this Support flash.


Users using IBM Connections Mobile will stop receiving Apple Push Notification Service (APNS) notifications after the certificates expire on 1/29/2016.


Download the iFix for your server version and apply. Some releases require a prerequisite iFix and the links for those are included.

IBM Connections Mobile v4.5 CR4 & CR5

IBM Connections Mobile v5.0 CR2

IBM Connections Mobile v5.0 CR3

       Prerequisite iFix LO86071 for v5.0 CR3

IBM Connections Mobile v5.5

       Prerequisite iFix for v5.5

IBM Connections 5.5 fix installation – a moment of panic and how to solve it

I installed the required fixes (,,, ) in my Connections 5.5 installation.

After doing this, I log in to Connections and I see this

As you can imagine I had a moment of panic. Why on earth has the UI reverted back to 5.0 ?
Thanks to the excellent Charlie Price of IBM I found the solution: go in C:\IBM\WebSphere\AppServer\profiles\AppSrv01\temp and delete everything in there; clear your browser cache and at the next log in everything will be back to normal 🙂

IBM Connections Docs 2.0 install guide

Me and the excellent Martti Garden have created an installation guide for IBM Connections Docs 2.0; it is a single-server installation, good for demo purpose or small environments where you do not need high scalability.

You can find it here
and here http://www.slideshare.net/RobertoBoccadoro/ibm-connections-docs-2-install-guide-56820027


Reinstallation of CCM fails. Here is the solution

I uninstalled CCM from my Connections deployment, and needed to reinstall it. When I ran Installation manager to install CCM, it failed; looking in the install.log under c:\IBM\Connections (my installation directory), I found this:

RUN: “C:\temp\5.2.1-P8CPE-WIN.EXE” -i silent -f “c:\IBM\Connections\tmp\ce_silent_install_windows.txt”
+ “C:\temp\5.2.1-P8CPE-WIN.EXE” -i silent -f “c:\IBM\Connections\tmp\ce_silent_install_windows.txt”
Exit code: 0
RUN: “C:\temp\” -i silent -f “c:\IBM\Connections\tmp\ceclient_silent_install_windows.txt”
+ “C:\temp\” -i silent -f “c:\IBM\Connections\tmp\ceclient_silent_install_windows.txt”
Exit code: 0
Replace place holders in template file [c:\IBM\Connections\lib\filenet\FNCS-] to new file [c:\IBM\Connections\tmp\FNCS-].
RUN: “C:\temp\IBM_CONTENT_NAVIGATOR-2.0.3-WIN.exe” -i silent -f “c:\IBM\Connections\tmp\FNCS-”
+ “C:\temp\IBM_CONTENT_NAVIGATOR-2.0.3-WIN.exe” -i silent -f “c:\IBM\Connections\tmp\FNCS-”
Exit code: 2000
RUN: “C:\temp\IBM_CONTENT_NAVIGATOR-” -i silent -f “c:\IBM\Connections\tmp\FNCS-”
+ “C:\temp\IBM_CONTENT_NAVIGATOR-” -i silent -f “c:\IBM\Connections\tmp\FNCS-”
Exit code: -1
ERROR: FileNet [fncs] installer [IBM_CONTENT_NAVIGATOR-] failed, exit code [-1]:

Seems Filenet installed correctly but Content Navigator no, there are two lines that caught my attention, those highlighted in red; the exit code of ICN 2.0.3 and of ICN 2.0.3 FP5. The last one is pretty clear, means an error, the first one is more mysterious for me, I don’t know what an exit code 2000 means.
The result of this is that Filenet and Content Navigator does not install, but in the list of installed programs in Windows you see Filenet. Pretty strange, no?

So I dug a bit deeper and under c:\IBM\Connections i found a directory FNCS that contained only a subdir “logs”, in which there were two files:
IBM_Content_Navigator_2.0.3_InstallLog.log and IBM_Content_Navigator_2.0.3_FP005_InstallLog.log.
Opening the latter, the cause of the error is very clear, it says:
Additional Notes: FATAL ERROR – Wed Dec 23 19:08:08:145 [ERROR] The install was aborted for the following reason: You must install IBM Content Navigator, Version 2.0.3.[0-4] before you can install the Fix Pack.
So seems it has not installed ICN 2.0.3, and looking at the first log I found this:
Additional Notes: FATAL ERROR – Wed Dec 23 19:07:09:782 [ERROR] The install was aborted for the following reason: The installer found the current version of IBM Content Navigator 2.0.3. Please uninstall and reinstall the application to fix the installation.
I was puzzled, how could the installer find an instance of ICN already installed?
A chat with a friend from IBM, the excellent Chad Scott, who had the same problem, turned out to be very useful; he told me this:
“FNCS 2.0.3 installation failed. The IBM_Content_Navigator_2.0.3_InstallLog.log says “The installer found the current version of IBM Content Navigator 2.0.3.”. As I know, FNCS 2.0.3 installer will check a registry file called “.com.zerog.registry.xml” before installation, if installer finds FNCS information in this xml file, it will report an error and exit. So I believe FNCS information has been written in this file at the first time you installed Connections with CCM. At the second time you tried, FNCS installer detected this information and exited directly.

So I went in C:\Program Files (x86)\Zero G Registry and found the file there. I opened it and indeed there were references to Filenet in there.
I cleaned it so that the file looked like this
<?xml version=”1.0″ encoding=”UTF-8″?>
<registry install_date=”2015-12-23 10:59:40″ version=”1.1″ last_modified=”2015-12-28 16:11:58″>



Then I ran regedit, went in HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Unistall and there were two references to Filenet and Content Navigator
I deleted them, so that Filenet did not appear anymore in the installed programs list.

Finally, I ran again Installation Manager to add CCM to Connections and everything worked fine.

Thanks Chad for pointing me in the right direction!

IBM Connections 5.5, a nice new feature of the installer

Today I installed Connections 5.5, and I discovered a nice new feature of the installer.

The installer performs the same steps as for Connections 5.0 up to the database connections; then there is a new thing. It asks if you want to Configure the IBM HTTP Server and you can choose “Do Now” or “Do Later”. If you choose “Do Now” it will configure automatically the applications to use the HTTP server, avoiding you to have to check out the LotusConnectionsConfig.xml file, edit it removing all the port numbers, and check it in again. Obviously if you select “Do Later” you’ll have to do that procedure manually, as it was in the previous versions of Connections.

Really nice, kudos to the developers for doing this.